1987 guage issue

Ask our auto mechanics for help to all your GMC truck questions.
Post Reply
Leroy22
Posts: 5
Joined: Tue Jan 31, 2017 11:50 am

1987 guage issue

Unread post by Leroy22 » Tue Jan 31, 2017 11:57 am

I have a 1987 GMC Sierra 3500 5.7 . with the gauges fuse in and I turn the key the fuel pump comes on like it should but after the time it should run I hear a click under the hood,sounds like at the carrb area, then the fuel pump keeps running and wount shut off. with the guaages fuse out the pump works as it should.
what the heck is it?

 

User avatar
carriedi
Posts: 2280
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1987 guage issue

Unread post by carriedi » Fri Feb 03, 2017 12:45 am

"I have a 1987 GMC Sierra 3500 5.7 . with the gauges fuse in and I turn the key the fuel pump comes on like it should"

Ok, got that,

"but after the time it should run I hear a click under the hood,sounds like at the carrb area, then the fuel pump keeps running and wount shut off"

ok, do you mean after you turn off the engine the fuel pump keeps running? running with the key in the off position? Then when you pull the gage/idle fuse the fuel pump turns off?

the only place where I see the gage/idle fuse circuit comes close to the fuel pump relay circuit is in the hot fuel handling module

is the click like a relay click or what? fuel pump relay on the firewall?
Attachments
87.jpg
87.jpg (212.28 KiB) Viewed 2082 times
hot ruel handling mod.jpg
hot ruel handling mod.jpg (234.5 KiB) Viewed 2082 times

Guest

Re: 1987 guage issue

Unread post by Guest » Mon Feb 06, 2017 12:24 am

thanks for the help:
with the guages fuse out just turning the key on without cranking the motor the pump runs like it should and then stops but with the gauges fuse in the pump runs for the time it should to build pressure then I hear the click and the pump keeps running.
after the click it sounds like its getting less volts to the pump.like it slows down a little.
does sound like a contact of sorts. I have put in a new pump relay,same thing

User avatar
carriedi
Posts: 2280
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1987 guage issue

Unread post by carriedi » Wed Feb 08, 2017 12:35 am

if your fuel pump relay is doing it's 2 second prime and then shutting off if the engine is not running, you should hear the relay click on, the fuel pump run and then after 2 seconds hear the relay click off and the pump turn off.

So are you hearing the relay clicking off and the pump continues to run or are you hearing something else clicking and the pump stays on?

the tan/white wire goes to the fuel pump. The tan/white wire is tied to the oil pressure switch, the fuel pump relay and the fuel handling module. The fuel pump module gets power from the gauges fuse. Without checking anything, it seems like the hot fuel handling module might the problem. Try unplugging it and see if the condition still exists.

this module should be located on the brake pedal bracket under the instrument panel

Leroy22
Posts: 5
Joined: Tue Jan 31, 2017 11:50 am

Re: 1987 guage issue

Unread post by Leroy22 » Wed Feb 08, 2017 4:13 pm

i'll check it out and get back with what I find. Thank you

Guest

Re: 1987 guage issue

Unread post by Guest » Sat Feb 11, 2017 5:48 am

I do hear the relay click and the pump does as suppose to with the fuse out.
with guages fuse in the pump primes and the clicks into another sound like the pump lost some voltage or its straining to run, (just an example of how it sounds) then keeps running. I haven't let it run long for the worry of melting wires or something else seeing it sounds like its straining.
didn't find the hot fuel module. What does it look like?

User avatar
carriedi
Posts: 2280
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: 1987 guage issue

Unread post by carriedi » Sun Feb 12, 2017 8:36 pm

here is an article that goes over that module
http://67-72chevytrucks.com/vboard/show ... p?t=429691

Post Reply