All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
I changed. the temp sensor. The temp gauge still on high after start the car. Can you plz tell me how to fix it.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2182
Images: 37
Location: Oregon
you need to hook up a scanner and see what the temperature reads. if the gauge doesn't match the temp reading you will probably need to have the cluster fixed or replaced


   
Reply with quote  
 

contributions: 2
Thank you, I'll try that.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first L300 2001 Heated seat switch

in Saturn

rmeyer

4

1471

Thu Jan 28, 2016 4:49 pm

rmeyer View the latest

New Articles View the first Rod knock saturn 2001 sc2

in Saturn

Cole1213

1

1792

Sat Jan 23, 2016 3:13 pm

carriedi View the latest

New Articles View the first 2007 saturn vue

in Saturn

CHRIS

1

1014

Tue Jul 19, 2016 2:49 am

carriedi View the latest

New Articles View the first 2007 saturn vue

in Saturn

CHRIS

1

1027

Thu Jul 21, 2016 10:30 am

carriedi View the latest

New Articles View the first My Saturn Astra!

in Saturn

SamuelLee

2

344

Thu Dec 28, 2017 3:07 am

SamuelLee View the latest

New Articles View the first Saturn Vue stalling

in Saturn

Paulranha69

1

252

Mon Feb 12, 2018 12:12 pm

carriedi View the latest

New Articles View the first Saturn vue transmission failure

in Saturn

ABF

1

526

Thu Jun 29, 2017 12:35 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us