All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
I have a 2008 GMC Envoy. This morning the engine coolant temp. gauge never moved, it stayed at cold while I was driving. The engine never got hot, the gauge just won't register. What do you think the problem is? Thank you.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2171
Images: 37
Location: Oregon
many times the sending unit is the culprit. It could be a loose connection or a bad sender. I have seen where the stepper motor in the instrument cluster has stopped working also but the sender is the place to start.

Using a scanner and look at the coolant temperature. It should give you the digital temperature if the sender is working. If the computer does see the correct temperature then I would start looking the gauge unit. You should get a check engine code coming up if the computer doesn't see the temperature come up to normal operating temp after a while. (P0128)


   
Reply with quote  
 

contributions: 2
Thank you.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2004 CHEVY SILVERADO GAUGE SEAT HEATER ISSUES

in Chevy Silverado

mikega

1

235

Sat Dec 30, 2017 5:20 am

carriedi View the latest

New Articles View the first Replacement engine

in Chevy Silverado

CrazyW

1

727

Sun May 14, 2017 7:04 pm

carriedi View the latest

New Articles View the first 4.3 engine swap

in GMC Trucks

Havok

6

1230

Sat Jul 29, 2017 11:50 pm

Havok View the latest

New Articles View the first Silverado 5.3L Engine swap

in Chevy Silverado

Brentz

4

1308

Fri Jun 23, 2017 8:36 am

ctel View the latest

New Articles View the first 07 Chevy engine swap

in Chevy Silverado

Taylor25

3

1546

Mon Nov 30, 2015 1:56 am

carriedi View the latest

New Articles View the first Reduced engine power

in Chevy Trailblazer

Guest

1

871

Sat Jul 02, 2016 1:17 pm

carriedi View the latest

New Articles View the first code P0106 Blazer ENGINE RUNNING HEAVY

in Chevy Blazer

DARKHARRIS

1

1489

Tue Jan 05, 2016 5:10 pm

tech3 View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us