All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 3
This code keeps popping up even after I replaced the camshaft position sensor. What else should I do? Gas mileage is terrible and there is a lunging while seating idle or when stopped at stop signs, etc.


Attachments:
4.2L Cam Solenoid.jpg
4.2L Cam Solenoid.jpg [ 3.44 KiB | Viewed 9606 times ]
Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 665
Unfortunately I don't have good news for you. If after replacing the sensor you still have the problem, that is usually the tell-tale sign of a stretched timing chain. Especially with the rought idle at stops, you definitely have an internal engine problem.

The only way to fix this is to replace the timing chain and associated parts. This requires a great deal of engine tear down and special tools. Along with the chain, sometimes the cams and/or other valve train items needs replaced due to wear and tear if the engine has a lot of miles on it, or was not maintained well.
_______________

GM Dealer Technician For 18+ Years
In the automotive industry for 20+


   
Reply with quote  
 

contributions: 3
This code came up over a year ago, at which time I replaced the camshaft position sensor.
Same code has now come back up. Someone at work told me I may need to replace both the camshaft and the crankshaft senors. Another code showing is an exhaust sensor, but i do not know the code #. Does any of this make sense?
Glenn


   
Reply with quote  
 
User avatar

contributions: 665
Replacing the crank sensor won't help any with this issue. You're going to have to have the engine looked at by a professional.
_______________

GM Dealer Technician For 18+ Years
In the automotive industry for 20+


   
Reply with quote  
 

contributions: 3
Replaced the variable timing solenoid and the spark plugs. Check engine light is gone, as well as the surging that was driving my wife crazy.


   
Reply with quote  
 

contributions: 1
thinks for sharing information


_______________
== http://www.solitairechamp.biz[ ==


   
Reply with quote  
 

contributions: 9
Just got the code p0014 on my 06 envoy i didn't change no sensor my mechanic advised be to change my oil and to put the correct amount... once i did the light went away... Now I'm not saying this will work on everyone but it worked for me


   
Reply with quote  
 

contributions: 1
Hey Gelmore, did you ever figure out and fix the code that was coming up for your exhaust? I have the same problem with my 02 Envoy right now. P0014, and P0420 which is something with the Cat or o2 sensor. I just dont know if i should try the o2 sensor because people say that it doesnt always fix it, and that i might need a whole new cat. Let me know what you did and what worked. Thanks.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 04 gmc envoy code c0055

in GMC Trucks

Anthonystull

1

2858

Tue Jan 26, 2016 11:31 am

carriedi View the latest

New Articles View the first 2004 GMC Envoy P0410 Trouble Code

in GMC Trucks

glenrr

1

355

Sat Mar 24, 2018 3:00 am

carriedi View the latest

New Articles View the first Gmc envoy

in GMC Trucks

Dwhid64

1

268

Fri Apr 06, 2018 9:34 am

carriedi View the latest

New Articles View the first GMC Envoy p/s cooler

in GMC Trucks

daveswall

1

1551

Sat Jul 04, 2015 9:13 pm

carriedi View the latest

New Articles View the first 03 envoy. Thermostat OE temp

in GMC Trucks

Cbvansickle

4

1835

Tue Sep 15, 2015 12:46 pm

butchkaz View the latest

New Articles View the first 2002 Gmc Envoy No Start

in GMC Trucks

Jamesh

3

905

Tue Sep 26, 2017 11:01 am

carriedi View the latest

New Articles View the first 1999 GMC Envoy won't start

in GMC Trucks

bjhatfi

5

1764

Fri Mar 17, 2017 1:34 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us