showing O2, MassAirflow Sensors and Cat. Conv. Problems

Alene62
Posts: 1
Joined: Wed Feb 28, 2018 9:18 pm

showing O2, MassAirflow Sensors and Cat. Conv. Problems

Unread post by Alene62 » Wed Feb 28, 2018 10:06 pm

I have been having problems with my 2002 Chevy Blazer for quit awhile now. Last Summer when the weather got hot, I would loose propulsion power. The Blazer would all of a sudden stop running at any speed. I would pull over to the side of the rode, restart it and continue on. The warmer the air was the more problems. Took to shop and they said it was the main computer board. I limped it back home because of the cost of the board. As the weather cooled off, it ran fine.
Then again I have similar problems. This time the rpm's would reeve up but I couldn't get it to go as fast as I know the rpm's would make it. So I took it back to the mechanic. This time they replaced the Mass Flow Sensor. It ran for about a week and again same problem but worse.

I don't remember what exactly they did (receipt in glove box at shop) the second time. But the check engine went off until I was a couple of miles down the road. However, it definitely ran better. Lasted 3 days.

Now, there's no way to go above 35. If there is any type of uphill slop, It would become worse and speed would go down to about 15 while the rpm's are at 3500. Today I found that if I would release the gas (as if driving a manual trans) I could get it to shift gears and speed up. This especially worked on flat or downhill slopes which is how I got up to 35mph. I had tried this before, to no avail.
This time the person working on it (same shop) told me that it's the catalytic converter. I called back to speak with the owner and asked for all codes because the check engine light has never went out since I've been taking it there. The owner said it was the O2 and mass flow sensors as well as the catalytic converter.

#1 - I was also told that the Blazer had 3 catalytic convertors. Is this correct?
#2 - I'm tired of getting strung along. Can you please give me some suggestions as to what is really wrong? I don't want to swap anymore parts. I'm going to sell it and just get it running better.

Thanks for any advice

 

User avatar
carriedi
Posts: 2280
Joined: Wed Apr 10, 2013 12:42 pm
Location: Oregon

Re: showing O2, MassAirflow Sensors and Cat. Conv. Problems

Unread post by carriedi » Thu Mar 01, 2018 12:15 pm

did you ask for the shop to write all the codes on your invoice? you should always ask that the codes that they scanned be written down on your paper work. this way you can always go to another shop and ask about the codes. My shop always gives the customer a print out of all the codes that come up. Hard codes, pending codes and sometimes the mode 6 information that relates to a specific problem like misfires that have not set a code yet but the customer can feel while driving.

don't ask what the codes were for, ask what the code numbers are.

Plugged cat. can affect driveability, the mass air flow sensor and slow the vehicle down at times.

Post Reply