All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
2004 buick lesabre bright lights will not work and the lamps are good


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2193
Images: 37
Location: Oregon
are you getting power to the high beam fuses in the underhood fuse panel? if you don't have power to the fuses the relay may not be turning on.You have a low beam relay and a high beam relay in the same fuse panel as the high and low beam fuses. See if the high beam relay is clicking as you turn the high beams on and off. If the relay clicks every time but you never get power to the high beam fuses you either have a bad contact in the relay of you don't have power to the C1 pin on the relay. switch the high and low beam relays to see if there is a problem with the relay. If switching the relays doesn't make any difference then you will need to verify the high beam circuit is working.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2003 buick regal instrument lights flash,ticking noise

in Buick

Parker2001

2

2209

Sun Feb 19, 2017 4:50 pm

fishmooften View the latest

New Articles View the first Attachment(s) my 99 buick lasabre

in Buick

continental67

2

1371

Wed Mar 08, 2017 2:09 am

carriedi View the latest

New Articles View the first 97 Buick lasabre

in Buick

BrokewithcarproblemsHELP

1

277

Sat Jan 27, 2018 6:28 pm

carriedi View the latest

New Articles View the first 99 Buick Regal problems

in Buick

Cooter75

1

1337

Wed Oct 19, 2016 10:58 pm

carriedi View the latest

New Articles View the first 2002 Buick Park Ave

in Buick

asimmons3325

6

376

Sat Jan 27, 2018 8:47 pm

carriedi View the latest

New Articles View the first 1994 Buick Park Avenue

in Buick

KaylaAnneKay

2

2057

Sun Dec 06, 2015 9:28 pm

KaylaAnneKay View the latest

New Articles View the first 97 Buick Skylark 3.1 crank no start

[ Go to page: 1, 2 ]

in Buick

Joelb0501

8

556

Wed Jan 17, 2018 12:00 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us