1998 Pontiac Transport Montana service engine soon codes P1665, P0452 and P0440. The
service engine lite has been on since I bought the car. I had the transmission replaced because 1st
and reverse were shot. And the van runs great, but my gas mileage has gone way down and the
service engine lite wont shut off.

I replaced the transmission and replaced the gas cap. The
front brakes and calipers were replaced
too. Could this be an oxygen sensor problem?

Answer:
EVAP system vent solenoid circuit.
P0452 fuel tank pressure sensor circuit low voltage.
p0440 - general EVAP system problem
Something in common with these 3 codes is the fuse labeled  CAN VENT SO which stands for
Canister Vent Solenoid. If this fuse is blown, it will cause all these codes. If fuse OK, then possibly a
problem at the fuel pump assembly connector on top of the fuel tank.

Another area that can cause electrical problems with these circuits is a pass-through harness
connector under the van. Sometimes it gets corroded and can cause these codes.


2001 Pontiac Montana 3.4L Check engine light code P1639 and P0452.
Question = My 2001 Pontiac Montana has been revving up anywhere from 1500 to 3000 rpms.
Went to Autozone to have them test it and got codes P1639 and P0452. I replaced the fuel pump a
couple months ago. What do these codes mean and how do I fix them?

Answer:
The P0452 code is for the Fuel Tank Pressure Sensor, and the P1639 is for the A/C Refrigerant
Pressure Sensor. Both of these sensors are on the same 5 volt signal circuit from the PCM, and
that is why both codes are set. There is something wrong that signal circuit to one of those sensors
and it is bringing the whole line down.

You could have pinched the wiring when you did the fuel pump, since the fuel tank pressure sensor
is located as part of the fuel tank module you removed. I'd check that out first, although you will
have to drop the tank again. Also, there have been problems with the body pass-through
connectors on the underside of the van. If you follow the fuel pump harness from the tank, you will
see it leads to a small bulkhead on the underside of the body. Check that connection for corrosion,
or water intrusion. If there is a problem with that area, you will need to replace that entire connector
assembly.

As for the revving up as you drive, I don't think your current codes would cause that problem. You
could have a transmission issue, that would need further diagnosis.

SHARE THIS PAGE ON ...
     




© Copyright 2006 . GreatAutoHelp.com
Terms And Privacy Policy
Contact Us

Pontiac Transport and Montana EVAP System Codes