Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
I changed. the temp sensor. The temp gauge still on high after start the car. Can you plz tell me how to fix it.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1944
Images: 37
Location: Oregon
you need to hook up a scanner and see what the temperature reads. if the gauge doesn't match the temp reading you will probably need to have the cluster fixed or replaced


   
Reply with quote  
 

contributions: 2
Thank you, I'll try that.


   
Reply with quote  
Ask A Question Reply   


   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first L300 2001 Heated seat switch

in Saturn

rmeyer

4

853

Thu Jan 28, 2016 4:49 pm

rmeyer View the latest

New Articles View the first Rod knock saturn 2001 sc2

in Saturn

Cole1213

1

1282

Sat Jan 23, 2016 3:13 pm

carriedi View the latest

New Articles View the first saturn ion transaxle

in Saturn

billyphillips

1

1203

Sat Mar 29, 2014 4:06 pm

carriedi View the latest

New Articles View the first Attachment(s) 1997 sl2 1.9 saturn

[ Go to page: 1, 2 ]

in Saturn

AaronMG21

15

2120

Mon Sep 15, 2014 10:41 am

carriedi View the latest

New Articles View the first 2007 saturn vue

in Saturn

CHRIS

1

419

Tue Jul 19, 2016 2:49 am

carriedi View the latest

New Articles View the first 2008 Saturn Vue XE

in Saturn

Ron

1

1241

Wed Sep 10, 2014 10:01 am

carriedi View the latest

New Articles View the first 2007 saturn vue

in Saturn

CHRIS

1

423

Thu Jul 21, 2016 10:30 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us