All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 3
I'm working on a Saturn with a 1.9 engine the car runs good when the engine is cold but, after it gets warm everytime you turn off, it floods and you have to hold the throttle all the way down to get it to start back. I've changed the fuel pump & the fuel pressure regulator / filter. HELP !


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2150
Images: 37
Location: Oregon
check your coolant temperature sensor. If the CTS reads cold all the time it will give your engine too much gas when the engine is warm. You need it to be richer with a cold engine but if it still reads cold when the engine is hot you will get too much gas.


   
Reply with quote  
 

contributions: 3
Thanks, the coolant temperature sensor fixed all my problems. The car runs better now than it ever has. I would've never thought that little sensor could make a car run so bad. Thanks again


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first saturn engine swap

in Saturn

jae

1

962

Fri Mar 18, 2016 10:23 am

carriedi View the latest

New Articles View the first f250 5.4 starts then stall no fuel , changed most fuel parts

in Ford Trucks

milkmandelight

4

1623

Sun Nov 13, 2016 12:09 am

Rachel View the latest

New Articles View the first Saturn Vue stalling

in Saturn

Paulranha69

1

40

Mon Feb 12, 2018 12:12 pm

carriedi View the latest

New Articles View the first My Saturn Astra!

in Saturn

SamuelLee

2

200

Thu Dec 28, 2017 3:07 am

SamuelLee View the latest

New Articles View the first 2007 saturn vue

in Saturn

CHRIS

1

866

Thu Jul 21, 2016 10:30 am

carriedi View the latest

New Articles View the first 2007 saturn vue

in Saturn

CHRIS

1

859

Tue Jul 19, 2016 2:49 am

carriedi View the latest

New Articles View the first 04 Saturn Vue AWD V6 hard starting

in Saturn

JGBuffy

1

1316

Wed Sep 30, 2015 9:35 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us