All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
having a problem with rr turn signal & brake lite 2011 Chevy express van. checked bulb its ok went to check fuses & found no provisions for fuses in under hood fuse block. checked fuse block under seat &found no brake or turn signal fuses whats up with that & where do I go from here?


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
your brake lights and tail lights are powered by the body control module. there is a park light relay and fuses for the park lights under the drivers seat. Check the Rt rear park lamp fuse. There are 4 fuses for the BCM in the under hood fuse box.

the right rear turn and brake comes from the BCM. they go to the drivers fuse box and then to the brake lights in the back. the right rear turn should be on the dark green wire from the bcm to the drivers under seat module. It comes out as dark green from the module but it turns to a yellow wire at the light.

With the right turn signal turned on, does the front turn signal flash? If the front is flashing then you need to check the wiring at the BCM and see if it is sending the signal to the light in the rear. If the Bcm is sending out the signal to flash the light then follow the wiring until you lose the signal to find the open in the circuit. Or, check to make sure you have a good ground at the light socket.


   
Reply with quote  
 

contributions: 1
Hello everyone one I'm first time user here so hope I'm doing everything right. I have a 2004 chevy express 3500 van and having a similar problem as one previously posted with signal and tidal light issues but I've checked fuses under hood and seat and all seam to be good . I see where there was talked about the BCM or there fuses and snot sure on the BCM itself being a issue or there's fuses as I checked them and all seem good. The problem started after I hooked LED. Lights up on my trailer and they all worked good but I did have to scratch around and clean the contacts on the trailer light plug was very dirty but after I did get them working and I noticed after everything was done I had no driver side rear signal or driver side brake light and the front signal blinks really fast. Any help or advice would be greatly appreciated. Thanks


   
Reply with quote  
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
so is the problem on the trailer lights or on the truck lights with the trailer not connected?


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Interior fuse accesories dont work

in Pontiac Grand Prix

eyj80962

3

569

Fri Sep 30, 2016 8:37 am

carriedi View the latest

New Articles View the first Gmc envoy wont restart gauges dont work

in GMC Trucks

Jodie

1

374

Fri May 12, 2017 1:59 am

carriedi View the latest

New Articles View the first driver side headlights dont work. wiring problem i think

in Chevy Trucks

Joshp

1

1080

Wed Oct 07, 2015 11:20 pm

carriedi View the latest

New Articles View the first turn signal bulbs

in Dodge And Chrysler

Yellowolf

2

529

Fri Mar 17, 2017 1:12 pm

Yellowolf View the latest

New Articles View the first Attachment(s) 99' Ford Explorer Sport turn signal multi switch

[ Go to page: 1, 2 ]

in Ford Trucks

MatthewinGA

9

838

Sat Jan 14, 2017 10:02 pm

MatthewinGA View the latest

New Articles View the first trailer brake and turn signals not working

in Ford Trucks

tinstar26

3

1400

Sat Nov 29, 2014 1:37 pm

tinstar26 View the latest

New Articles View the first Attachment(s) my camera dont come on can you help

in GMC Trucks

allieair13

4

1504

Wed Dec 24, 2014 4:53 pm

allieair13 View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us