GreatAutoHelp.com Car Forums
http://greatautohelp.com/forums/

charging system on older rv
http://greatautohelp.com/forums/viewtopic.php?f=69&t=6683
Page 1 of 1

Author:  psycomyko [ Mon Jul 28, 2014 7:30 pm ]
charging system on older rv

i have a 1978 dodge tradesman (b200) rv.new problem is with head lights on engine stalls upon stop. ping,charge gauge drops to discharge prior to stall.with headlights off no stall.allso very hard to restart after stall. alternator and voltage regulator replaced 6 m0. ago fuel fiter replaced 2 days ago runs much better but still didnt solve problem. i pulled positive battery cable when running no change motor ran fine

Author:  mudn4life [ Mon Jul 28, 2014 7:56 pm ]
Re: charging system on older rv

I would check for ground issues. If your lossing ground to the head light switch due to a broken wire or a ground strap not being tight enough or corrosion. then the circuit will could find a ground threw something else wich could cause the issue you are having. the best way to check for that is at the back of the head light switch back probe the ground circuit and check for voltage when you turn the switch on if any voltage is present then you are lossing ground due to a high resitstance or open circuit. now you can add a ground by over laying the circuit or you can look for were the issue is wich would mean getting a wiring diagram and locating splices and ground locations and isolating and load testing circuit but before running a load test make sure you have isolated the circuit because if not the voltage could damage another componet that might share the circuit..

Author:  Guest [ Sat Dec 31, 2016 10:21 pm ]
Re: charging system on older rv

Aloha,
I had the same problem on my 77 dodge farwest motorhome... Mine decided to quit on a busy street, at the light, at rush hour... that was pleasant...
Fortunately, my brother in law was a dodge service manger.. Ballast Resister On the firewall I even got his discount at the parts store. I don't know if I ever would have figured that one out... Purring again.

Also replaced the cap and rotor in a tuneup... drove to the beach (50 Mi.) and it would barely run... mechanic friend said, "Always use Factory parts on critical systems"... Lucky for me, he had a Mopar cap... I put it on and she purred. Amazing, and I had bought the best brass pole cap I could find.

Put the same vehicle in storage.. when I went back to get it, all the belts blew up, and it was really fun running up and down the hill to the parts store, trying 4 belt sizes at a time until I hit the right combo. Lesson: motorhome engines and accessories are anything but stock... no documentation, so... do yourself a favor, draw yourself a diagram of the pulleys and belt sizes for your rig and put in a drawer in the truck.

Got it running and was taking it to friend's house to get it ready to move far down the road, and stopped at a stop sign... when I hit the brakes, ALL the exterior lights went off at once, even the four-ways. it was like a carnival... The cop at the intersection had just driven away and was going around the corner, so I was grateful not to have to explain. Tail-light assemblies were corroded, so I replaced them, and ADDED A GROUND for the rear lights... tapped into the rear lights ground, the tail light assemblies grounds, and ran it to the welded bumper cross brace between the frame rails. Soldered a flat round connector, drilled a small hole and bolted the connection... Lights fixed. Lights seem to often be bad connection issues, often the ground.

Also had a Jeep Wagoneer... same sorts of issues... My car guru buddy said ground.. ADDED another ground cable... all better.

Also have a newtome old 89 dodge dakota, just tuned up, new disto, coil, plugs, wires, cap, rotor, fuel filter and lines, and muffler (which really sucked to do, involving laying on ones back, working above your face with a chisel and hammer, and pneumatic chisels, and pain) still having the loss of power issue, Just less, which is why I am here, and your post reminded me of the above rv puzzles. So next week, it; off to Mopar for cap and rotor... even though the aftermarket cap brass looks nice......? Now to test the O2 sensor in the exhaust pipe, it tells the E-Brain (SMEC) what's on the way out, (exhaust) so it can control what comes in (the fuel/air mixture).
While I was replacing the muffler, I replaced two ground cables from the cab to the bed that had corroded away. Grounds, again.
I hope it's not the cat... that job looks real sucky.
Good luck.. wear gloves... yes, it's work the 20 bucks
Happy New Year Mike

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/