Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
Just changed rear wheel bearing on AWD drive version. Now the ABS, traction control, air bag and brake lights are all on. The speedometer is also no longer working. It works fine for 2 minutes and then everything as described happens. Any help is appreciated


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2002
Images: 37
Location: Oregon
If everything was working normally before I would go over the work that was done. If you did it yourself, go back and recheck everything. If you had a shop do it, take it back to them.

What should be done is have your vehicle scanned for codes and graph the wheel speed sensors to see what they are doing.


   
Reply with quote  
 

contributions: 2
Yes everything was working before we changed it. No lights or anything. The bearing simply was bad. Now the bearing issue is gone but we now have all the lights


   
Reply with quote  
 
User avatar

contributions: 2002
Images: 37
Location: Oregon
yep, I would look to see if the wheel speed sensor is hooked up and working.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2007 ford freestyle wrench light comes on and will not shift

in Ford Cars

DRDUFFY

2

658

Fri Feb 10, 2017 8:39 pm

MaxTurn63 View the latest

New Articles View the first Attachment(s) 2006 ford Taurus

in Ford Cars

Mitchellgrice

1

1624

Sat Sep 20, 2014 11:28 pm

carriedi View the latest

New Articles View the first 2006 Ford F150 5.4 Brake light & ABS Light on ??

in Ford Trucks

dynamitejake96

6

2002

Sun Dec 07, 2014 9:03 pm

dynamitejake96 View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us