Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 
i but a new battery in my 1999 ford taurus n now the raido dont work at all


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 319
Images: 4
First thing to do is check the fuses. If you jump started it, or caused a spark when replacing the battery, you may have blown a fuse. You could have also damaged the radio if it does not work at all.


   
Reply with quote  
Ask A Question Reply   


   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) 2006 ford Taurus

in Ford Cars

Mitchellgrice

1

1427

Sat Sep 20, 2014 11:28 pm

carriedi View the latest

New Articles View the first 2007 Ford Taurus won't start

in Ford Cars

pisces67

2

1549

Tue Oct 07, 2014 10:34 am

pisces67 View the latest

New Articles View the first 2005 Taurus stubborn p0300

in Ford Cars

davidkien68

1

1160

Mon Jan 12, 2015 10:44 pm

carriedi View the latest

New Articles View the first do I need A new Battery?

in Ford Trucks

woods5511

1

1028

Thu Jan 01, 2015 5:33 pm

carriedi View the latest

New Articles View the first 2001 Expedition; dying and will - NEW alternator and battery

in Ford Trucks

glminor

1

1521

Mon Jan 04, 2016 3:30 am

carriedi View the latest

New Articles View the first 92 ford f150

in Ford Trucks

stacey

3

2192

Mon Oct 27, 2014 10:36 am

carriedi View the latest

New Articles View the first Ford F-150 egr problems

in Ford Trucks

earnie

1

1232

Thu Feb 12, 2015 12:04 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us