All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 
i but a new battery in my 1999 ford taurus n now the raido dont work at all


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 319
Images: 4
First thing to do is check the fuses. If you jump started it, or caused a spark when replacing the battery, you may have blown a fuse. You could have also damaged the radio if it does not work at all.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Replacing the Catalytic converter(s) on a 1996 Windstar 3.8L

in Ford Cars

segehrand

1

451

Sat Apr 01, 2017 8:07 pm

carriedi View the latest

New Articles View the first 2005 Taurus stubborn p0300

in Ford Cars

davidkien68

1

1477

Mon Jan 12, 2015 10:44 pm

carriedi View the latest

New Articles View the first do I need A new Battery?

in Ford Trucks

woods5511

1

1291

Thu Jan 01, 2015 5:33 pm

carriedi View the latest

New Articles View the first 2001 Expedition; dying and will - NEW alternator and battery

in Ford Trucks

glminor

1

1816

Mon Jan 04, 2016 3:30 am

carriedi View the latest

New Articles View the first Ford F-150 egr problems

in Ford Trucks

earnie

1

1515

Thu Feb 12, 2015 12:04 am

carriedi View the latest

New Articles View the first 92 Ford Escort

in Ford Cars

Tibo

1

1789

Fri Nov 28, 2014 10:53 pm

carriedi View the latest

New Articles View the first 2007 ford

in Ford Cars

amanda

1

1713

Sat Nov 22, 2014 5:03 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us