All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
Need some help here ran great one day next day wont crank over ,starter will crank when jumped with screw driver,battery good tested, also have no gear indicator or fuel gauge,thought ign. switch but has power and send power when held in crank position..need some direction as to where to go next since no gear indicator and fuel gauge is reading E ..Thanks for any advice.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
I'm a little confused, "ign. switch has power and send power when held in crank position" sends power to what? You said it won't crank but when you hold the key in the start position it should send a signal for thr starter to crank the engine over. Does it?

it kinda sounds like ignition switch to me. At least that's one of the things I would check.

verify that you have a good ground from the battery to the chassis and to the engine.

fuse boxes also have problems on some models. the circuits inside the fuse box can lose connection causing an open circuit. PCM and BCM also have problems that will look like what you have. See if you can scan for engine and body codes. see what it says


   
Reply with quote  
 
Did u figure out the issue with your envoy not starting? I have the same issue, all the gauges work except the fuel gage. I replaced the ignition switch but didn't help.


   
Reply with quote  
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
if your starter is now turning the engine over when it is supposed to make sure you have battery voltage on the purple wire to the starter solenoid. If you have battery voltage on that wire and the starter doesn't work you probably have a bad starter. (as long as your grounds are good) If you don't have battery voltage on the purple wire check the starter relay. what is the relay doing? you will need to check the signals at the relay (#47) connection to the under hood fuse box on the left side of the engine compartment.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) New battery leakage or overheat on a 2002 GMC ENVOY

in GMC Trucks

sedar59

5

1363

Sun Dec 07, 2014 8:45 pm

carriedi View the latest

New Articles View the first 1999 GMC Envoy won't start

in GMC Trucks

bjhatfi

5

1215

Fri Mar 17, 2017 1:34 am

carriedi View the latest

New Articles View the first 06 gmc envoy xl 4x4

in GMC Trucks

david

1

1290

Sat Nov 22, 2014 5:28 pm

carriedi View the latest

New Articles View the first GMC Envoy p/s cooler

in GMC Trucks

daveswall

1

1154

Sat Jul 04, 2015 9:13 pm

carriedi View the latest

New Articles View the first 2003 GMC Envoy SLT 4.2 will not idle

in GMC Trucks

jlo4short

2

1500

Thu Feb 12, 2015 5:18 am

tezoost View the latest

New Articles View the first Yukon Envoy Transmission

in GMC Trucks

zombiejoe81

1

1117

Fri May 15, 2015 10:55 pm

carriedi View the latest

New Articles View the first 06 envoy idle problem

in GMC Trucks

Beginnermechanic

1

1126

Wed Mar 23, 2016 10:17 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us