All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
Hello! I have an 02 envoy. SUV currently has 186,000 miles. I was taking my wife to work this morning (with wind chill it was -18 degrees out) after driving for a few on main roads we could smell oil "burning" I chalked it up to vehicles around us because mine has never leaked a drop of anything in the 2 yrs we have owned it, anyways the smell would come and go then it didn't go away. By this time I had been driving the vehicle for approx 15 mins motor was at normal temp which is just under 210. I pulled into a gas station and looked underneathe and could see oil dripping so I turned the truck off popped the hood and the whole passenger side of the motor had been sprayed with oil. I had it towed to the shop and they cleaned up all the oil and can not find out where it is coming from. They said nothing is leaking and everything is tight and I had a full 7qts of oil (4.2l carries 7qts) they (the shop) said they had another envoy in a couple weeks ago with the same problem and like with mine, they could not find the problem. Please I need help I'm at my witsend with this envoy


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
most leaks aren't real bad. it's just that, if you don't check your engine very often, when you find a leak it's because it has leaked for so long it causes a problem. (like burning smell or smoke) Clean off the motor and affected area and wait a couple days. check to see if you can see where the leak seems to be coming from. Valve cover gaskets are very common leaks. From there the oil leaks down and can get oil over everything.

Another problem it sometimes the porosity of the metal components is a problem. but just clean everything off and watch for the leak to return.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first driver side headlights dont work. wiring problem i think

in Chevy Trucks

Joshp

1

1079

Wed Oct 07, 2015 11:20 pm

carriedi View the latest

New Articles View the first Motor & Transmission

in Chevy Venture Van

Cristian720

1

926

Wed Sep 30, 2015 12:47 am

carriedi View the latest

New Articles View the first after turning on the motor,it shuts right back of

in Chevy Suburban

Chavez

1

956

Thu Nov 06, 2014 6:46 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us