Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 
1992 Olds 88 Sat for 2 years. Was running well. Starts up, then stalls, and makes banging noise.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2002
Images: 37
Location: Oregon
bad gas? what kind of knocking noise? Like a rod knock?


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) 92 Oldsmobile 88 no spark

in Oldsmobile

Muse2max

1

1205

Tue Jul 29, 2014 9:30 pm

carriedi View the latest

New Articles View the first 2001 oldsmobile alero

in Oldsmobile

krispy24

1

1201

Sun Jun 29, 2014 1:59 am

carriedi View the latest

New Articles View the first 04 Oldsmobile Alero has No brakes!!!

in Oldsmobile

Beginnermechanic

2

646

Thu May 05, 2016 7:25 am

Beginnermechanic View the latest

New Articles View the first Attachment(s) oldsmobile auroua a/c problem

in Oldsmobile

jpruntich

1

742

Fri Mar 18, 2016 10:38 am

carriedi View the latest

New Articles View the first Oldsmobile Aurora A/C defroster

in Oldsmobile

nicholeup

1

965

Sat Oct 04, 2014 2:32 pm

carriedi View the latest

New Articles View the first 1995 Oldsmobile Oil leak

in Oldsmobile

matthewmarcum

1

468

Fri Feb 10, 2017 9:33 pm

carriedi View the latest

New Articles View the first Attachment(s) 1998 Oldsmobile 88 Starting problems

in Oldsmobile

dsljohn

4

1364

Mon Jul 07, 2014 12:15 am

dsljohn View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us