Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 
1992 Olds 88 Sat for 2 years. Was running well. Starts up, then stalls, and makes banging noise.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1944
Images: 37
Location: Oregon
bad gas? what kind of knocking noise? Like a rod knock?


   
Reply with quote  
Ask A Question Reply   


   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) 92 Oldsmobile 88 no spark

in Oldsmobile

Muse2max

1

1070

Tue Jul 29, 2014 9:30 pm

carriedi View the latest

New Articles View the first 99 oldsmobile bravada

in Oldsmobile

RhondaJ07

1

705

Thu Jun 19, 2014 9:56 am

carriedi View the latest

New Articles View the first Oldsmobile Alero leaking oil

in Oldsmobile

jlemke19792014

1

1021

Sun Apr 20, 2014 4:09 pm

carriedi View the latest

New Articles View the first 2001 oldsmobile alero

in Oldsmobile

krispy24

1

1063

Sun Jun 29, 2014 1:59 am

carriedi View the latest

New Articles View the first 04 Oldsmobile Alero has No brakes!!!

in Oldsmobile

Beginnermechanic

2

508

Thu May 05, 2016 7:25 am

Beginnermechanic View the latest

New Articles View the first Attachment(s) oldsmobile auroua a/c problem

in Oldsmobile

jpruntich

1

597

Fri Mar 18, 2016 10:38 am

carriedi View the latest

New Articles View the first Oldsmobile Aurora A/C defroster

in Oldsmobile

nicholeup

1

872

Sat Oct 04, 2014 2:32 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us