All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
i have a 97 olds royale 88 wont start i have replaces the crank sensor plugs wires fuel pump and filter got good fuel pressure and good spark not sure where to go next


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2092
Images: 37
Location: Oregon
Is your security light on? if the security light is on or flashing the pcm may be disabling the injector pulse.


If you have measured the fuel pressure and you are within specs and you know you have good spark, you need to check your injector pulse. Unplug one of the injectors from the wire harness. use a test light between the two wires in the injector wire harness connector and crank the engine over. The light should blink as the engine is cranked over. It won't blink very fast because you are only cranking the engine so the rpm's are low but you should see if the signal is opening the injector or not.

both the cam and crank sensor send their signals to the ignition control module. The ignition module fires the coils. but the injector signal goes to the PCM and the PCM fires the injectors. The pink wire to the injectors is power from Injector fuse (10A) in the right side dash fuse panel.
the injectors are grounded by the pcm to open the injector.
#1 black wire
#2 light green and black
#3 pink and black
#4 light blue and black
#5 black and white
#6 yellow and black


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 1990 88 Royale wont start when hot

in Oldsmobile

FUDFUH

1

920

Mon Jul 18, 2016 4:36 pm

carriedi View the latest

New Articles View the first Attachment(s) '99 Olds 88 lowbeams

in Oldsmobile

Ecald02

3

596

Wed Mar 22, 2017 12:12 am

carriedi View the latest

New Articles View the first ac on a 2002 Olds Bravada

in Oldsmobile

kj1956

6

1408

Sat Apr 04, 2015 6:14 pm

kj1956 View the latest

New Articles View the first ICM burn up 99 Olds silhouette 3.4

in Oldsmobile

rschneider

1

583

Tue Dec 27, 2016 4:25 am

carriedi View the latest

New Articles View the first 2002 olds Silhouette

in Oldsmobile

Tbartif6

3

725

Wed Mar 22, 2017 12:19 am

carriedi View the latest

New Articles View the first 2002 olds alero obd codes

in Oldsmobile

momofkmal

1

597

Mon Apr 17, 2017 10:49 am

carriedi View the latest

New Articles View the first 98 Olds Achieva electrical problems

in Oldsmobile

mjwettoes

1

1114

Tue Sep 22, 2015 10:18 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us