All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I have a 1995 oldsmobile aurora with a full tank of gas it will crank up but when I press the gas peddle it sputters and then cuts off what could cause this to happen?


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2036
Images: 37
Location: Oregon
you should check your fuel pressure. spec is 41 to 47 psi key on engine off


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Oldsmobile Aurora A/C defroster

in Oldsmobile

nicholeup

1

1006

Sat Oct 04, 2014 2:32 pm

carriedi View the latest

New Articles View the first oldsmobile aurora hood wont open

in Oldsmobile

deerojas76

1

983

Mon Apr 06, 2015 5:45 pm

carriedi View the latest

New Articles View the first Grand Prix engine stalls when turn on lights

in Pontiac Grand Prix

gunny

3

928

Mon Nov 30, 2015 2:09 am

carriedi View the latest

New Articles View the first 2004 Grand Prix, loss of power at lower speed & stalls

in Pontiac Grand Prix

jenninky

4

1386

Mon Oct 12, 2015 8:59 am

jenninky View the latest

New Articles View the first 1995 Oldsmobile Oil leak

in Oldsmobile

matthewmarcum

1

513

Fri Feb 10, 2017 9:33 pm

carriedi View the latest

New Articles View the first 1995 Olds Cutlass supreme

in Oldsmobile

smibgal

3

1649

Fri Jan 27, 2017 5:29 am

gotolds View the latest

New Articles View the first 1995 Grand Prix Gtp won't idle

in Pontiac Grand Prix

Pipeboy

1

610

Wed Apr 13, 2016 12:46 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us