All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
i have a 2005 chevy venture van with a 3400 sfi v6, here's the problem the car cranks perfectly and idles great but after driving it for 15 mins. or so the check engine light blinks and it loses power dramatically, the motor idles real rough but does not quit. after turning it off and letting it sit for five mins.it cranks and runs fine until it seems it heats back up and then it does it again. but it does not do it all the time. especially in the morning when its cooler outside. any clues ?????


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 

contributions: 2
would the line from the pcv valve that goes into the top of the intake and back to the evap switch have anything to do with it????


   
Reply with quote  
 
User avatar

contributions: 665
Sounds like you definitely have a heat related problem which is usually caused when a certain sensor glitches out after it get hots, or the vehicle has been driven a while. I don't think the line from the pcv would have anything to do with it, since if it was bad, or was causing a vacuum leak, the problem would happen all the time cold or hot.

Since the check engine light is blinking, it's obviously sensing a misfire condition when the van is running rough. It most likely would have set a misfire code, and possibly any other code that is related to the problem. You may want to get it scanned just to check those codes since that can help lead you in the correct direction for diagnosis.

Some things I've seen cause issues like this would be a faulty crank sensor, cam sensor, or ignition module. Any of those can be affected by engine heat and be fine again after it cools off.
_______________

GM Dealer Technician For 18+ Years
In the automotive industry for 20+


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Started low idle, runs rough

in Chevy Trailblazer

kinsy2323

1

564

Sat Mar 11, 2017 7:35 pm

carriedi View the latest

New Articles View the first Attachment(s) 2005 venture electrical problem

in Chevy Venture Van

jerrythompson

1

434

Sun Oct 23, 2016 10:16 pm

carriedi View the latest

New Articles View the first 2005 Envoy 4.2 in line 6 cyl, rough idleing,

in GMC Trucks

bobmcelyea

4

1988

Fri Apr 24, 2015 10:28 am

carriedi View the latest

New Articles View the first doesnt drive past 30

in GMC Trucks

Beginnermechanic

1

767

Sat Sep 03, 2016 1:10 pm

carriedi View the latest

New Articles View the first 2014 Grand Caravan Radio doesnt work

in Dodge And Chrysler

DTK

1

246

Sat Sep 16, 2017 3:06 am

carriedi View the latest

New Articles View the first Dodge Ram 1500 quit running fuel leak

[ Go to page: 1, 2 ]

in Dodge And Chrysler

dodgeram

12

2286

Fri Sep 23, 2016 6:57 pm

carriedi View the latest

New Articles View the first 2005 Chevy suburban 5.3l v8 misfire

in Chevy Suburban

Dmantooth

1

366

Sun Jan 22, 2017 3:19 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us