Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 3
i have a 1995 silverado 5.7liter 350 engine, i replaced the motor,the other motor had 225,000plus miles. after replacing the motor it will not idle,and stalls out when stopping, also noticed that the motor surges, when applying the throttle it will rev up,but it will try to die off unless you let off accelerator a little and reapply. I had a trouble code of # 22 t.p.s, I replaced the throttle position sensor, m.a.p sensor, and the idle air control sensor,however i am still having the problem, it is throttle body injected, and there arent any other codes showing up.
Any help would be much appreciated.

Clay


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 319
Images: 4
Hello Clay.
Was the engine replaced with a new or used engine?
If used do you have history on it?
_______________

Be sure to check the Similar questions down this page for more help.


   
Reply with quote  
 

contributions: 3
yes sir it was new(rebuilt), I had bought it as a long block,(from an engine supply co.) had bought the truck used, knowing i was going to need to replace the motor,it was running on 5or6 cylinders, compression was bad on 2or3, i was saying this because it was running bad, but not dying out, maybe running so bad that it wasnt dying out?? I used the same intake manifold and throttle body, I have put approx. 1000 miles on this "new motor" my wife and i were working close to each other so truck has been sitting for about 6months. Theres been a change so i need the truck now. I recently started working on it, code scan was saying 22 which according to the book is t.p.s (throttle position sensor) orfuel cutoff relay circuit-open or grounded. I replaced the t.p.s(throttle position sensor),the m.a.p.(manifold absolute pressure sensor), and the i.a.c(intake air control sensor), i have tried to some brake cleaner to check for vaccum leaks havent found any.After replacing the t.p.s reran trouble code scan it came back clean, no trouble codes but truck running the same.

hopefully this will help you help me, there was something on this reply about a donation, i definitely will make one when once i pick your brain and hopefully figured this out, i didnt catch your name on reply but thanx

Clay


   
Reply with quote  
 

contributions: 3
just for more info, when i was doing engine swap i thoroughly cleaned the throttle body, is there a fuel pressure regulator in it, can it be replaced? is there a way to test? I cant afford to keep throwing money at it replacing parts.

Again thanx
Clay


   
Reply with quote  
 
User avatar

contributions: 319
Images: 4
The names Terry.
Ok. I was going to say look for a vacuum leak, but you have already. Make sure the brake booster is not leaking. You can unplug the large vacuum hose from it and plug it off to see if that helps.

Check if the EGR valve is stuck open or the gasket is leaking. To check if stuck open, you should be able to get your fingers on the underside and move the diaphram. Also disconnect and plug off the vacuum hose.

You shoud look close at the TPS connector wires. Give a tug on each little wire to see is one of them stretches. If one does, that means the core is broken so the colored insulation will stretch. If your scanner shows engine data, look at TPS voltage with engine off / key on and pressing gas slowly to the floor. The reading should increase smoothly.

On the throittle body injected, the regulator it located on top of the throttle, by the injectors, but that does not sound like your problem unless it is blowing black smoke.

Check ignition timing. The distributor may be off a little.

Also, you say the other engine was running bad? If it way running bad for a while, the catalytic converter may be plugged. Disconnect them and see how it runs.
_______________

Be sure to check the Similar questions down this page for more help.


   
Reply with quote  
 
Hoping I can get in on this conversation. I have the same issue, I have checked all of the conventional repair and diagnosis ideas and cannot resolve. The TBI injectors are getting a good signal and I can watch the pulse and inject fuel in the start mode and immediately peter out in the idle mode. I have run a jumper wire to the ground on both injectors and am able to make the engine run at idle by tapping the ground on the battery. I find no vacuum leaks and can see the EGR function.
Very stumped. Looking for any insight.
Thank you.


   
Reply with quote  
 
User avatar

contributions: 1988
Images: 37
Location: Oregon
you're probably going to need to have someone scan your truck and have a lab scope to verify what is happening with your fuel injectors.

Since you can supply your own ground for the injectors and keep the engine running then we should look at the injector pulse width. What the scanner shows the computer pulse width signal is and compare it to the lab scope. Things that will affect the pulse width is the mass air flow sensor, coolant temp sensor, O2 sensor, throttle position sensor and the distributor. You should be able to scan for codes first and then look at the data stream to see what the truck is doing.

have you checked your fuel pressure? you may get the truck to run by supplying ground and turning the injectors on but you may be holding the injectors on longer allowing more fuel than the computer is allowing. Need to check what the computer is doing on the ground side of the injector


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 1995 Chevy fullsize Silverado

in Chevy Silverado

craig420

1

1334

Sun Nov 16, 2014 10:23 am

carriedi View the latest

New Articles View the first 1995 c-2500 2 wd 5.7 l auto high idle, bangs into gear

in Chevy Trucks

kwbush

1

1529

Sun Jun 08, 2014 9:13 pm

carriedi View the latest

New Articles View the first 1995 chevrolet silverado z71 dies out

in Chevy Silverado

Tacklebox

3

1388

Wed Dec 30, 2015 4:00 pm

carriedi View the latest

New Articles View the first 98 silverado will fire but not idle

in Chevy Silverado

bigrig9135

4

1576

Wed Feb 11, 2015 11:49 am

bigrig9135 View the latest

New Articles View the first NEED HELP! 2005 Silverado Idle Problems

in Chevy Silverado

CamSilverado

1

273

Mon Apr 17, 2017 9:55 am

carriedi View the latest

New Articles View the first Attachment(s) 92 silverado 7.4 liter manual trans wont turn over

in Chevy Trucks

stevep

1

290

Thu Nov 03, 2016 12:26 am

carriedi View the latest

New Articles View the first 1981 chevy wont start after shut it off for a while

in GMC Trucks

1936chevy

2

1116

Fri May 29, 2015 7:30 am

1936chevy View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us