All times are UTC - 6 hours [ DST ]




Ask A Question Reply    Go to page 1, 2  Next
Author Message
 

contributions: 5
Guys I need some help.
I bought a 1994 z71 350 automatic. When the truck sits for a while the parking brake light comes on within the first minute or two of driving. Soon after the light comes on I start having a slight loss in acceration at low rpm. When it gets close to shifting, at higher rpm, I have a complete loss of acceration, almost like it shifts into neutral because it revs up. If I let off the gas it shifts and then the cycle repeats. Then my speedometer starts jumping around. Sometimes my service engine light comes on with it but sometimes it doesn't. The only other problem I have is that the brakes are pretty spongy and the temp gauge hardly budges (I am no expert so I don't know if a faulty temp sensor or such could be related). After it does this and then sits for a while it doesn't do it again. As long as I drive it at least every other day it will not do this. But more than that you can bet that light will come on. When I bought it I replaced the front pads, rotors, cv shafts, fuel filter, oil and filter, air filter, plugs, tps, and knock sensor. I also had a trans shop replace all the trans seals and gaskets plus filter. I'm out of ideas. Thanks in advance for the advice.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
you should drive it with a scanner on it and see what the data stream is doing. See if any codes are stored in memory. this way you can verify the coolant temperature too. You can then scan the data stream for the trans too. see if the trans has codes and is slipping.


   
Reply with quote  
 

contributions: 5
I took the truck to O'Reilly's and their code reader said something along the lines of unable to communicate. When I had the tranny seals and gaskets replaced at the dealership was when this problem started and I took it back to them. They ran their code reader and they cleaned some parking brake connections and said the reader was showing a bad O2 sensor. Neither of which helped.


   
Reply with quote  
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
so is the brake light not coming on anymore?


   
Reply with quote  
 

contributions: 5
Yes it is. If I drive it often it won't happen. The longer it sits the greater the chance the light comes on and when the light comes on the other problems follow.


   
Reply with quote  
 
User avatar

contributions: 2056
Images: 37
Location: Oregon
how is your battery and charging system? are the battery terminals and ground connections good and clean? could there be a voltage problem?


do your truck have anti-lock brakes


   
Reply with quote  
 

contributions: 5
I can check and clean the terminals tomorrow. I know the battery is about 3 years old. Yes it has ABS.


   
Reply with quote  
 

contributions: 5
Well no luck diagnosing the problem so far. Here are the clues. Parking brake light comes on when these problems occur. Truck surges, reflects this on the tach at all RPM, and/or completely loses power at high RPM. Codes have been pulled and read running lean. Temp gauge reads too low (hardly budges after running for a while). Lastly I can't trace the source but I can smell gasoline every once in a while outside of the vehicle. No visible leaks on concrete. Thanks for the help!


   
Reply with quote  
Ask A Question Reply    Go to page 1, 2  Next

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) 95 suburban electrical issues

[ Go to page: 1, 2 ]

in Chevy Suburban

Meangreen

11

1301

Sat Jan 23, 2016 6:15 pm

Meangreen View the latest

New Articles View the first 95 blazer fuel issues

in Chevy Blazer

j4ml3

3

888

Sun Apr 17, 2016 1:44 pm

carriedi View the latest

New Articles View the first Chevy Suburban Starting Issues

in Chevy Suburban

ivanhoe

4

1361

Sun Jun 28, 2015 11:47 pm

carriedi View the latest

New Articles View the first Attachment(s) GMC Sierra No brake lights

in GMC Trucks

dirtman

5

1775

Sat Apr 18, 2015 10:56 pm

carriedi View the latest

New Articles View the first Brake line 2004 Blazer

in Chevy Blazer

b17b17b17

6

424

Tue Aug 15, 2017 11:09 am

b17b17b17 View the latest

New Articles View the first 2011- Service Trailer Brake System

in Chevy Silverado

GAH11

3

1354

Wed Dec 31, 2014 6:38 pm

carriedi View the latest

New Articles View the first Smog Test/Service Engine Light

in Chevy S-10 Pickup

chevyfan

3

1120

Sat Nov 08, 2014 7:03 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us