All times are UTC - 6 hours [ DST ]




Ask A Question Reply    Go to page Previous  1, 2
Author Message
 

contributions: 5
The $.12 problem So I was wrong after about 50 miles light came back on. At this point I decided there has to be an air leak somewhere. So I bought me two cans of carb cleaner and a piece of hose went around the entire engine. Check every fitting everything. Couldn't find a air leak anywhere. What I did notice is the oil fill extender tube did not fit very well. The O-ring was bad I also noticed. That right next to the filler tube is an air intake hose that connects to the throttlebody just before the blades It's meant to supply fresh filtered air into the engine and then the sucked out by the PCV valve But because the O-ring was leaking it was now sucking air into the throttlebody. Bypassing the mass airflow sensor Which is more than likely throwing that reading off and was what was causing my code Also the PCV valve it would now be sucking air directly through the leaking O-ring. So basically what I figured out it's because that O-ring was leaking it resulted in a massive air leak At least that's what the computer thought The engine looks at the position of the throttle the air coming into the engine and the RPM if those three don't match then we got a problem. I'm pretty confident that was the problem the truck is never ran better I'm at 75 miles right now on my way to get my state inspection. Thanks


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2126
Images: 37
Location: Oregon
The IAC counts should have shown a low count for the unmetered air. that's what the IAC does. It's a vacuum leak that is controlled by the computer. Glad you found the problem. Hope all goes well now. Happy driving.


   
Reply with quote  
Ask A Question Reply    Go to page Previous  1, 2

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2001 chevy silverado 1500 4.8 new alt and battery, still die

in Chevy Silverado

AcurazFinest52

4

402

Mon Jul 31, 2017 3:28 am

carriedi View the latest

New Articles View the first GMC 2001 Sierra does not always start!

in GMC Trucks

rkcrump

1

742

Wed Oct 19, 2016 10:54 pm

carriedi View the latest

New Articles View the first 2001 Chevy Tahoe

in Chevy Tahoe

ChevyRider

1

156

Tue Dec 19, 2017 2:15 am

carriedi View the latest

New Articles View the first Attachment(s) Chevy 2001 4.3 blazer hose melt

in Chevy Blazer

roy33

2

591

Wed Dec 28, 2016 3:36 pm

Guest View the latest

New Articles View the first 2001 GMC sierra 1500 4x4 vibration in floor when acceleratin

in GMC Trucks

shackleferd33

1

1255

Wed Nov 25, 2015 1:51 am

carriedi View the latest

New Articles View the first 2001 Chevy 4.3 Blazer Trany stays in 2nd & speedo @ zero

in Chevy Blazer

roy33

1

450

Sat Jan 07, 2017 1:11 pm

carriedi View the latest

New Articles View the first 89 silverado

in Chevy Silverado

chuyluna

1

1309

Sat Nov 14, 2015 9:20 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us