All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
having accelaeration problems with stalling codes p0120&p0220


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 7
Location: Chicago
Check for poor grounds at the back of each cylinder head.

You may need a new throttle body.


   
Reply with quote  
 

contributions: 2
thank you for your reply i will check that ive been an import technician for several years this is just an odd problem because somtimes the dang thing will run perfect and everything ive ohmed out seems to be within in specs


   
Reply with quote  
 
User avatar

contributions: 7
Location: Chicago
OK since your a tech I can give you a more in depth diagnosis procedure.


1. Check pin terminal connections at the plug to the throttle assembly underhood.

2. Probe a voltmeter to the Dark Green wire at the Throttle Position Sensor (TPS) and monitor for a glitch in the signal voltage.

3. Inspect the Yellow Throttle Actuator Control (TAC) motor control circuit #581 about 1 inch to 4 inches from the throttle body connector to see if it is broken inside of the insulation. (There is a tsb on this)


   
Reply with quote  
 
User avatar

contributions: 2089
Images: 37
Location: Oregon
if the code is cleared and doesn't come back right away it could be an intermittent problem. That being said, if it is intermittent, all the resistances may check out normal. you should drive it with a graphing scanner hooked up and hopefully while you are driving the problem pops up and you can look at the graph to see what signal to check out. There is a TSB about the wire harness connector having breaks inside the insulation and there are some that say it could go back as far as ten inches from the connector.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2003 ford escape xlt car will not start no power

in Ford Trucks

msladya1

2

19

Tue Dec 12, 2017 4:31 am

carriedi View the latest

New Articles View the first Tahoe oil gauge pressure at zero

in Chevy Tahoe

georgenikkichevytahoe

1

834

Tue Mar 17, 2015 10:22 am

carriedi View the latest

New Articles View the first Chevy Tahoe 5.7 transmission issue

in Chevy Tahoe

BIGLAM79

4

808

Sun Apr 09, 2017 11:31 am

BIGLAM79 View the latest

New Articles View the first 2000 Tahoe Transmission/TCase problem

in Chevy Tahoe

GhostTown80

1

555

Tue Nov 08, 2016 12:44 am

carriedi View the latest

New Articles View the first 4l60e transmission swap from a 99 tahoe into an 02 yukon

in GMC Trucks

CrazyW

1

97

Sat Nov 18, 2017 5:55 pm

carriedi View the latest

New Articles View the first No power to coil

in Chevy Silverado

Skeeter73

2

1621

Wed Aug 24, 2016 1:23 am

bad View the latest

New Articles View the first 89 gmc sierra no power

in GMC Trucks

georgenikkichevytahoe

1

1291

Tue Mar 17, 2015 10:26 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us