GreatAutoHelp.com Car Forums
http://greatautohelp.com/forums/

2001 Chevy 4.3 Blazer Trany stays in 2nd & speedo @ zero
http://greatautohelp.com/forums/viewtopic.php?f=39&t=7583
Page 1 of 1

Author:  roy33 [ Fri Jan 06, 2017 12:10 pm ]
2001 Chevy 4.3 Blazer Trany stays in 2nd & speedo @ zero

The speedometer stays at 0 all the time. When the transmission is in drive it won't come out of 2nd gear. I replaced the VSS on rear of tranny. Same problems. I had a burnt harness near the ECM unit. Rewrapped all wires. Still no speedo or shift. Still searching on the web for answers. Any help would be great.

Author:  carriedi [ Sat Jan 07, 2017 1:11 pm ]
Re: 2001 Chevy 4.3 Blazer Trany stays in 2nd & speedo @ zero

you should hook up a scanner to your truck and look at codes that would put your trans into limp mode. Verify that you have a good VSS signal when the vehicle is moving. If you show the normal speed on the scanner but the instrument cluster reads nothing then you need to look and the cluster and the wiring to the cluster. If you don't have a vehicle speed sensor reading (sensor reads zero) while the truck is moving at the rear wheels then Look at the wiring from the VSS to the ECM since you have already replaced the VSS sensor.

If you have a multimeter that has frequency, you could test the signal for the VSS at the PCM. PPL/WHT wire, pin 21 connector 2 and LT GRN/BLK wire, pin 21 connector 2. the voltage reading should be at least 0.5volts (and up as speed continues to rise) but you are looking for frequency, frequency should be around 4K pulses per mile.

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/