Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 2
The speedometer stays at 0 all the time. When the transmission is in drive it won't come out of 2nd gear. I replaced the VSS on rear of tranny. Same problems. I had a burnt harness near the ECM unit. Rewrapped all wires. Still no speedo or shift. Still searching on the web for answers. Any help would be great.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1957
Images: 37
Location: Oregon
you should hook up a scanner to your truck and look at codes that would put your trans into limp mode. Verify that you have a good VSS signal when the vehicle is moving. If you show the normal speed on the scanner but the instrument cluster reads nothing then you need to look and the cluster and the wiring to the cluster. If you don't have a vehicle speed sensor reading (sensor reads zero) while the truck is moving at the rear wheels then Look at the wiring from the VSS to the ECM since you have already replaced the VSS sensor.

If you have a multimeter that has frequency, you could test the signal for the VSS at the PCM. PPL/WHT wire, pin 21 connector 2 and LT GRN/BLK wire, pin 21 connector 2. the voltage reading should be at least 0.5volts (and up as speed continues to rise) but you are looking for frequency, frequency should be around 4K pulses per mile.


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Attachment(s) Chevy 2001 4.3 blazer hose melt

in Chevy Blazer

roy33

2

304

Wed Dec 28, 2016 3:36 pm

Guest View the latest

New Articles View the first 99 2500 speedo not working

in GMC Trucks

oldchev

1

1265

Mon Apr 04, 2016 11:46 pm

TerryAuto View the latest

New Articles View the first 2001 chevy impala

in Chevy Cars

daisha

1

1593

Sat Nov 08, 2014 6:33 pm

carriedi View the latest

New Articles View the first 2001 Chevy Malibu check engine code p0446

in Chevy Cars

bjjmerrill

1

1339

Sat Sep 13, 2014 3:44 pm

carriedi View the latest

New Articles View the first 95 Blazer won't turn over???

in Chevy Blazer

SnowDaddy

3

849

Wed Jul 23, 2014 9:59 pm

carriedi View the latest

New Articles View the first 95 blazer fuel issues

in Chevy Blazer

j4ml3

3

689

Sun Apr 17, 2016 1:44 pm

carriedi View the latest

New Articles View the first 88 Blazer high idle

in Chevy Silverado

nutlug

3

1281

Wed Oct 21, 2015 11:01 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us