Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 4
I'm having some issues with a 95 blazer hoping y'all can help. It's been sitting since 07. I began with a crank but no start and started with the fuel pump which was rusted to death and obviously bad. Cleaned tank and new fuel filter but still no start. Checked fuel pressure at manifold which a pretty steady 60#. I cracked open the intake to check the spider injector. I hooked up a noid light and I'm only getting injector pulse for about three seconds. Will only do that once unless you unhook battery. I read that the security could cause a similar situation but after a call to the best local locksmith they say it does not take a chip key so what else could be my problem. Thanks in advance


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1947
Images: 37
Location: Oregon
do you have spark the whole time you are cranking? or does the spark disappear too?

you should use a scanner and verify you are getting a cam and crank sensor signal


   
Reply with quote  
 

contributions: 4
It has spark the whole time it will run on ether. I have scanned it with obd2 reader and there are no codes no check engine lights


   
Reply with quote  
 
User avatar

contributions: 1947
Images: 37
Location: Oregon
might have to use a graphing multimeter or a lab scope and see what is happening with the signals that control your fuel injector pulse.


   
Reply with quote  
Ask A Question Reply   


   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first fuel lines 97 blazer

in Chevy Blazer

backanforth10to2

1

346

Thu Dec 08, 2016 10:19 pm

carriedi View the latest

New Articles View the first f250 5.4 starts then stall no fuel , changed most fuel parts

in Ford Trucks

milkmandelight

4

967

Sun Nov 13, 2016 12:09 am

Rachel View the latest

New Articles View the first 95 Blazer won't turn over???

in Chevy Blazer

SnowDaddy

3

816

Wed Jul 23, 2014 9:59 pm

carriedi View the latest

New Articles View the first Attachment(s) Heater issues

in Buick

Noglory51491

4

995

Wed Feb 03, 2016 5:58 pm

carriedi View the latest

New Articles View the first Starting issues

in Chevy Cars

ivanhoe

2

1301

Thu Feb 05, 2015 11:41 am

ivanhoe View the latest

New Articles View the first 88 Blazer high idle

in Chevy Silverado

nutlug

3

1246

Wed Oct 21, 2015 11:01 am

carriedi View the latest

New Articles View the first 1998 jimmy is new to me and having many issues

in GMC Trucks

heatherfaye

1

969

Wed Jun 25, 2014 8:20 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us