All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
2001 Blazer LS problems overheating, hose blew, car would not start. Mechanic stated that radiator not flushed before and low gas and oil 2 quarts low, engine may be blown?


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2126
Images: 37
Location: Oregon
it may be that you have a blown engine but I think you need a little more than the info given to decide that. How hot the engine got, why doesn't it start, what is the condition of the oil, hows the coolant situation, does the engine turn over? Does the engine cranking over sound normal or dose it seem to turn over faster than normal like no compression?


   
Reply with quote  
 

contributions: 2
You must provide more details to analyse the problem in detail .Since a professional from a car mechanic shop has told you about the problem I think it might be true.....


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 03 T&C radiator fan troubles

in Dodge And Chrysler

MrJoshua

1

1044

Mon Mar 14, 2016 1:57 pm

MrJoshua View the latest

New Articles View the first 2004 Ford Expedition oil leak at radiator

in Ford Trucks

Droptine61

1

634

Sat Dec 31, 2016 10:11 pm

carriedi View the latest

New Articles View the first Attachment(s) HELP !! - Coolant leaking from behind brass radiator fittin

in Dodge And Chrysler

ScottyB

1

1209

Wed Oct 21, 2015 10:30 am

carriedi View the latest

New Articles View the first Ford F-150 egr problems

in Ford Trucks

earnie

1

1632

Thu Feb 12, 2015 12:04 am

carriedi View the latest

New Articles View the first 99 Buick Regal problems

in Buick

Cooter75

1

1009

Wed Oct 19, 2016 10:58 pm

carriedi View the latest

New Articles View the first Both sliding doors have problems

in Toyota Car And Trucks

paulrhyan

1

564

Wed Apr 13, 2016 12:55 am

carriedi View the latest

New Articles View the first Attachment(s) 98 Regal 3.8 Voltage Problems

in Buick

Justaguy

4

1763

Sun Jan 22, 2017 3:27 pm

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us