All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
I have gotten a oil change and all my fluid checked and filled, a tune up and a new battery. When I accelerate, it goes real slow then it speeds up a little and then it goes slow again. It is not my tranmission. I suspected it is my egr valve. Any ideas. Please help


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 2071
Images: 37
Location: Oregon
you should have a scanner hooked up and drive it so you can see what the computer sees. Check the exhaust backpressure for a restricted exhaust... Fuel filter? (would show up in the fuel trims)

do a lot of checking before you start replacing parts


   
Reply with quote  
Ask A Question Reply   

   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first 2003 chevrolet impala

in Chevy Cars

pinetree

3

1845

Fri Apr 21, 2017 12:31 am

Guest View the latest

New Articles View the first 2003 Chevrolet Impala 3.4 liter

in Chevy Cars

Culpiesr2

1

388

Sat Sep 16, 2017 2:57 am

carriedi View the latest

New Articles View the first Chevy Impala Won't Crank Over

in Chevy Cars

capricebb

1

618

Wed Mar 15, 2017 1:13 am

carriedi View the latest

New Articles View the first 2005 Chevy Impala ignition

in Chevy Cars

gw5301989

1

114

Fri Nov 03, 2017 5:27 am

carriedi View the latest

New Articles View the first 2002 Chevy Impala-Instrument Panel Lights

in Chevy Cars

Rinda

7

2412

Thu Jan 01, 2015 5:53 pm

carriedi View the latest

New Articles View the first Blower motor 2004 Chevy impala wont shut off

in Chevy Cars

Konradtown

1

1289

Tue Apr 05, 2016 12:00 am

TerryAuto View the latest

New Articles View the first 2003 Chevy S-10 Stall out

in Chevy S-10 Pickup

Sling

1

456

Wed May 03, 2017 8:49 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us