Quantcast




All times are UTC - 6 hours [ DST ]




Ask A Question Reply   
Author Message
 

contributions: 1
Hey need help, I have a 99 Buick Century Limited, I just had a motor put in about 3 months ago, the car drives good it's just that when I drive it like 3 or 4 blocks it cuts off, but it starts back up. Also I have no heat, I put AntiFreeze in there still doesn't work. Could any one help with this question please, would greatly appreciate it.


Share on FacebookShare on DiggShare on DeliciousShare on TechnoratiShare on TumblrShare on Google+
   
Reply with quote  
* Search   
 
User avatar

contributions: 1898
Images: 37
Location: Oregon
you should talk to the place where you had the motor put in. ask them if the problem might be related to the work they did.

you should drive the vehicle with a scanner that has a data stream that can graph and you can see what happens just before the car dies. See if it's fuel, reference voltage, or whatever you can see that changes and causes the engine to die.

On the "no heat" you should get the engine up to normal operating and feel the two heater hoses that go in through the fire wall to the heater core and see if both of the hoses are hot. If one is hot and the other not, you may have a plugged heater core. If both hoses are hot you should look at the heater blend door. Maybe the heater door that moves to adjust temperature isn't moving from the cold side.


   
Reply with quote  
Ask A Question Reply   


   Similar Topics   Author   Replies   Views   Most Recent 
New Articles View the first Buick Century idling eratically

in Buick

BethsCentury

6

2717

Sat Jan 03, 2015 2:09 am

carriedi View the latest

New Articles View the first Attachment(s) 93 Buick century special transmission problem

in Buick

sawred

3

2902

Fri Feb 14, 2014 9:08 am

carriedi View the latest

New Articles View the first Power Steering locked up while driving my 02 Buick Century.

in Buick

Mike84

3

2306

Sat May 23, 2015 1:15 pm

carriedi View the latest

New Articles View the first car trouble

in Buick

locklear2020

1

1048

Mon Nov 03, 2014 4:27 pm

carriedi View the latest

New Articles View the first 99 Buick Regal problems

in Buick

Cooter75

1

257

Wed Oct 19, 2016 10:58 pm

carriedi View the latest

New Articles View the first 95 Buick regal won't start help please

in Buick

jeff88

6

3119

Fri Aug 14, 2015 1:42 pm

amyb View the latest

New Articles View the first 2000 Buick LeSabre Custom

in Buick

ginhartmann

3

2124

Wed Mar 26, 2014 3:43 am

carriedi View the latest


All times are UTC - 6 hours [ DST ]



Search for:
Jump to:  
Contact Us