All times are UTC - 6 hours [ DST ]




Ask A Question    Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
 Questions   Author   Replies   Views   Most Recent 
New Articles View the first Slows down and overheats

opn6

1

726

Sun Jan 26, 2014 3:15 am

carriedi View the latest

New Articles View the first 1999 Olds Aurora blows fuse for dash and Air

lance0267

1

871

Sun Jan 26, 2014 3:13 am

carriedi View the latest

New Articles View the first too lean bank 1 sensor 1 code p0171 Olds intrigue 2001

raceday

2

1835

Wed Jan 22, 2014 12:21 am

Karl View the latest

New Articles View the first Leaking antifreeze and sloshing sound in my dash...Ugh!

Cspradlin18

2

1383

Mon Jan 20, 2014 11:32 pm

Cspradlin18 View the latest

New Articles View the first 1992 Olds 88 Royale Cold start issues (FYI)

fallenknight73

5

1206

Mon Jan 06, 2014 9:22 pm

carriedi View the latest

New Articles View the first 1999 Olds Cutlass temp gauge runs hot

Crawdaddy74

1

1051

Fri Jan 03, 2014 2:44 am

carriedi View the latest

New Articles View the first 1999 Oldsmobile Aurora air conditioining Repair Cost

DGroth

2

1223

Fri Dec 27, 2013 11:33 pm

celsoQ View the latest

New Articles View the first 2001 Aurora Temp Sensors

KAR

1

848

Fri Dec 20, 2013 6:42 pm

carriedi View the latest

New Articles View the first Olds Intrigue Heater control goes blank

pandk

2

1161

Thu Dec 19, 2013 8:41 am

pandk View the latest

New Articles View the first 1993 Oldsmobile 88 Royale clicking noise

unfortunateGuy

1

936

Sun Dec 15, 2013 6:43 pm

carriedi View the latest

New Articles View the first Oldsmobile Silhouette has No Heat

redrobin

2

1167

Thu Dec 12, 2013 2:13 pm

redrobin View the latest

New Articles View the first Attachment(s) 1997 olds 88 vacuum diagram

eastsider5

1

1402

Tue Dec 10, 2013 9:14 pm

carriedi View the latest

New Articles View the first 96 Olds Ciera Cluster of Some Sort Bad

Geary

4

1064

Wed Nov 27, 2013 11:47 am

carriedi View the latest

New Articles View the first Oldsmobile Headlights not working

Nord1120

5

1923

Mon Nov 11, 2013 3:56 pm

Nord1120 View the latest

New Articles View the first 2004 ALero help!! nothing works!

LVALENZ

1

1021

Thu Oct 24, 2013 7:21 pm

carriedi View the latest

New Articles View the first 2002 olds intrigue p0410 code

brendarline66

1

1036

Sun Sep 08, 2013 4:14 pm

carriedi View the latest

New Articles View the first ground wires in Oldsmobile Intrigue

brendarline66

1

1341

Sun Sep 08, 2013 3:49 pm

carriedi View the latest

New Articles View the first Olds Alero wont start or turn over, gauges go crazy

whitea5

2

1605

Tue Aug 20, 2013 10:44 pm

butchkaz View the latest

New Articles View the first possible high ehxaust manifold temp.

jeffyg

2

660

Wed Aug 14, 2013 8:51 pm

jeffyg View the latest

New Articles View the first Changed PCM in 1998 Olds Aurora. Now no start

Terry

1

848

Tue Aug 13, 2013 10:15 pm

carriedi View the latest

New Articles View the first Oldsmobile Intrigue defrost problem

Cosmo

1

934

Tue Jul 30, 2013 2:02 am

carriedi View the latest

New Articles View the first overflow tank leak

fdba08

1

722

Mon Jul 01, 2013 7:42 pm

carriedi View the latest

New Articles View the first No heat 1998 Oldsmobile Intrigue

Cosmo

3

1369

Thu Jun 27, 2013 2:45 am

carriedi View the latest

New Articles View the first Attachment(s) Part name...2000 Alero 3.4L v6

mikneg

3

1429

Wed Jun 26, 2013 10:58 am

carriedi View the latest

New Articles View the first 2001 olds silhouette making faint odd ding noise

Doittoday

1

930

Sat Jun 22, 2013 4:17 pm

TerryAuto View the latest

New Articles View the first Oldsmobile Intrigue no start or turn signals

magookennedy4th

1

1232

Thu Jun 20, 2013 11:04 pm

carriedi View the latest

New Articles View the first 1995 Olds 88 stalls intermittently, intake gasket related?

hooah175

1

1077

Sun Jun 02, 2013 9:05 pm

TerryAuto View the latest

New Articles View the first 97 Cutlass Supreme 3.1L Misfire in cylinder 3

glockgal2010

4

1464

Tue May 28, 2013 5:48 pm

glockgal2010 View the latest

New Articles View the first instrumental cluster not working

blancaarcila

1

837

Sun May 26, 2013 9:33 pm

ProTech View the latest

New Articles View the first Engine Coolant Warning Light

dandettman

1

801

Fri May 24, 2013 7:49 pm

ProTech View the latest

Ask A Question    Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next

All times are UTC - 6 hours [ DST ]


Search for:
Jump to:  
Contact Us